Google Chrome - Foro de ayuda

Re: CONFLICTOS con CHROME y FLASH en la ULTIMA ACTUALIZACION

DIPLOX
28/05/13 14:41
Me esta pasando lo mismo y a los usuarios de la red que desarrollamos tambien ya que me estan llegando muchos correos comentando esto...
Soy desarrollador de la WEB: www.DIPLOX.COM y todo arranco con la actualizacion 27.0.1453.94 m, que segun pude ver tiene el flash incorporado.
si se desactiva en los pluging el flash y se vuelve a activar en una pestaña, la web en la otra carga rápido y completa pero si se la refresca otra vez el problema hasta que se cancela y activa como digo antes el flash en los plugins

Creo que no es lógico que por una actualización los navegantes tengan que realizar cambios de configuración en sus equipos, mas taniendo en cuenta que la mayoría utiliza las máquinas y no son tecnicos para entender y realizar estos cambios...

Y tampoco es lógico que los sitios tengan que adaptarse de un día para otro para adecuarse a los requerimientos de un navegador

En los otros navegadores anda bien incluso en el dragon basado en chrome...

Gracias por sus comentarios
RJD

Respuestas (9)

DIPLOX
28/05/13 15:07
Tengo problemas con el chrome y los flash de las webs y a los usuarios de la red que desarrollamos tambien les esta pasando lo mismo ya que me estan llegando muchos correos comentando esto...
fpardo
28/05/13 16:09
Hola DIPLOX, es una pena que Flash vaya mal con tu página pero no lo pagues con nosotros publicando 8 veces lo mismo. 

Sobre tu problema mira los siguientes hilos a ver si te dan alguna idea:

Kamgoo
29/05/13 2:06
Buenas Fpardo:

Mi nombre es Carlos, y lo que comenta Diplox no es un problema personal de el o de su pagina, es un problema global, que ocurre en la version 27.0.1453.94 m.

Yo soy un desarrollador web de una Red Social, Kamgoo, Y cuando en una misma pagina se cargar varios objetos flash, a veces, y digo a veces, porque a veces si cargan todos los objetos, otras veces uno o ninguno.

Y es un error de carga, porque si los objecto los separo en varias paginas y lo conecto con iframe, todos los objectos cargan correctamente....

Y estoy hablando de una web de 220.000 usuarios donde estoy teniendo muchisimas quejas porque no pueden ver contenido flash, cuando en internet explorer y firefox y demas exploradores funciona correctamente. A parte de que la web lleva asi 3 años.... Ahora tengo que modificar todo el codigo? o es que es un fallo de la ultima version de Google Chrome?

Un saludo

Carlos
Kamgoo
29/05/13 2:08
Perdon, olvidaba decir que los ejemplos que pones para arreglarlo, que van al mismo hilo, no funcionan.

Carlos

(desconocido)
29/05/13 2:20
<Se ha eliminado este mensaje.>
Kamgoo
29/05/13 2:36
Buenas He mirado lo de la consola javascript y no unico que me muestra es esto..
Unknown RPC service: widget-interactive-I0_1369819898720 cb=gapi.loaded_0:115
Unknown RPC service: widget-interactive-I0_1369819899366 cb=gapi.loaded_0:115
Unknown RPC service: widget-interactive-I0_1369819899416 cb=gapi.loaded_0:115
Unknown RPC service: widget-interactive-I0_1369819899354 cb=gapi.loaded_0:115
Unknown RPC service: widget-interactive-I0_1369819899379 cb=gapi.loaded_0:115

Carlos

DIPLOX
1/06/13 10:44
Estimado Kamgoo,

Te comento que utilizando la ayuda para Webmásters creado por el usuario Luis Favre nuestra web esta andando mejor con chrome...

En nuestro caso, agregamos el código para las funciones onReady y onLoad de jQuery, y demora un poquito mas, (Al terminar de cargar recarga nuevamente), pero en el 90% / 95% de las oportunidades al terminar de cargar se ve todo...

Adjunto visualizaciones previas al parche, y si la miras en línea www.diplox.com  veras las diferencias...

Aca el código que paso LUIS...

Para Webmásters creado por el usuario Luis Favre

Buscando encontre unas lineas de codigo en jQuery que solucionan el problema (por ahora zafamos) y es bastante simple. A continuación detallo...

en el head de la pagina cargan jQuery (si ya lo estan usando no es necesario)...
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js" ></script>

y al final agregan este Javascript...
<script type="text/javascript">
        $(document).ready(function(){
                if(window.navigator.appVersion.match(/Chrome/)) {
                        jQuery('object').each(function() {
                             jQuery(this).css('display','block');
                        });
                }

        });
</script>
DIPLOX
1/06/13 10:48
perdon...

www.diplox.com/new

para ver el sitio público sin logearse...

saludos
Kamgoo
3/06/13 6:04
Entonces ya carga todo?.. Por ahi lei que estan arreglando la version y sacaran una version nueva de chrome...
Yo intente a hacer ese truco pero no me funciono.. voy a intentarlo de nuevo a ver si lo hice mal.

Gracias por todos

Carlos