Google Chrome - Foro de ayuda

Actualizar Adobe Flash Player

Antonio Guzmán
15/10/12 0:47
Hola. Desde hace una semana, me salen mensajes en Chrome, que dicen que flash no está actualizado, se me bloquean algunos contenidos, etc... El problema es que no puedo actualizarlo, porque me dice que no es necesario en Chrome, y que posiblemente está inhabilitado, lo cual es falso. Es un círculo vicioso que me lleva siempre a esta URL http://get.adobe.com/es/flashplayer/?no_redirect, en la cual lo dice bien claro. Y los mensajes de error siguen saliendo.

Para más información uso Chrome desde un Mac Pro con el MAc OS X 10.5.8

Muchas gracias

Respuestas (6)

Alejandro Silvestri
15/10/12 4:07
Flash viene incorporado en Chrome.  Es posible que, además, lo hayas instalado por tu cuenta, y la instalación doble cause conflictos.  Si es así se corrige inhabilitando una instalación desde chrome://plugins .  Más información en este enlace:

Antonio Guzmán
18/10/12 0:43
Gracias por tu respuesta Alejandro.

Sí he instalado flash por mi cuenta, ya que me sale una barra amarilla del propio Chrome en la parte de arriba con un botón que dice "actualizar". Al meterme en "chrome://plugins" flash no aparece duplicado, sino que me sale lo siguiente:

Flash - Versión: 10.3.183.29 Descargar actualización de seguridad crítica
(con el número de la versión en rojo)

Si le doy a actualizar, me sale la misma página que comentaba en la pregunta inicial, con un flash descargable para Opera, Firefox y Ópera.

Lo que no entiendo es que si Flash se actualiza solo en Chrome, por qué me pide que lo actualice.
Alejandro Silvestri
26/10/12 6:16
Ok, lamentablemente el tema no es simple, los términos son bastante confusos.
Adobe tiene una línea de Flash llamada PEPPER, diferente de la normal.
La normal es un plugin que se descarga de la página de Adobe.  Ese plugin usa interfaz NPAPI, que trae problemas (los problemas de siempre)
En cambio pepper, es una manera de hacer las cosas que le permite a los desarrolladores de navegadores (como Chrome) desarrollar ellos mismos parte del código de Flash e incorporarlo en el navegador.  Usa interfaz PPAPI en lugar de NPAPI, que consigue un Flash más veloz y que se cuelga menos.  La contra es que la parte del Flash pepper que se desarrolla para Chrome no sirve para Firefox, y así, cada navegador, si quiere tener estas ventajas, necesita que sus desarrolladores hagan su propia versión de pepper Flash.

Chrome tiene pepper Flash preinstalado, y que se actualiza junto con el navegador.  Ahora bien, si vos además instalás el plugin, entonces Chrome tendrá dos Flash.  No los necesita, de hecho trae conflicto.  El que te pide actualización debe ser el plugin, no el pepper.

Podés ir a chrome://plugins e inhabilitar el Flash de tipo NPAPI.
mortak
6/12/12 1:03
Muchas gracias Alejandro , problema resuelto en Chrome , alguna solucion para firefox?
Alejandro Silvestri
14/12/12 3:26
Hola, Firefox es un excelente navegador, Chrome aprendió mucho de las innovaciones de Firefox.
Yo personalmente abandoné Firefox cuando me pasé definitivamente a Chrome.  Antes había abandonado IE por Firefox.
Si bien no creo que en este foro consigas ayuda para ese navegador, me parece que Firefox sigue con su viejo NPAPI, sin intenciones por ahora de moverse a PPAPI (es un enorme esfuerzo de desarrollo).  Por su parte Adobe dijo que seguirá haciendo versiones de Flash para navegadores específicos como IE y Firefox, pero que los demás navegadores vean de implementar su propio PPAPI como Chrome.
Patricia Pozo Valderas
19/12/12 12:37
Hola!!pues yo he seguido los pasos de inhabilitar el flash que no pertenece a google chrome y me sigue saliendo el mensaje de que uno de los complementos shockwave flash no responde!
Y he probado incluso a inhabilitar el flash de google y dejar el otro, pero ni esas!:((
Donde más error me da es en Facebooky hotmail...
Qué más puedo hacer?!
Graciaaas!